You need to update your iPhone and Mac NOW as Apple races against time to stop hackers


Apple has launched a security update to address a critical new vulnerability impacting iPhone, iPad and Mac owners. The flaw is a zero-day vulnerability, which, in a nutshell, is about as bad it gets.

For those who don’t know, a zero-day vulnerability refers to a flaw in software that’s already known to hackers. That means the issue isn’t simply academic – instead, every day that goes by without the security fix leaves you open to scam artists using the issue to exploit people worldwide.

Zero-day vulnerabilities are a race against time to get as many people as possible to install the patch.

Apple devices impacted by the new flaw include iPhone 6s or newer, all iPad Pro models, iPad Air 2 or later, iPad mini 4 or newer, iPad 5th generation or later, and iPad Touch (seventh-generation). MacBooks, iMac, Mac Pro, and Mac mini machines running macOS Big Sur will need to be updated to the new update too – as all of these devices are vulnerable.

“Apple is aware of a report that this issue may have been actively exploited,” the Californian company confirmed in a security briefing published earlier today. The vulnerability, which is referred to as CVE-2021-30807 by Apple internally, is a memory corruption issue.

MORE LIKE THIS
Sky Q, Fire TV and Samsung TV users gained a new ‘world first’ update

However, little else is known about the flaw. That’s pretty normal in these situations. Since Apple has confirmed that it’s aware of hackers using the memory corruption bug to attack devices in the real world, withholding details about the issue is a good tactic to stop more bad actors finding out about the problem – and taking advantage of unpatched gadgets.

We’d expect to hear more details in the coming months, as the update is installed by the billion or so iPhone owners worldwide.

To update your iPhone to the latest version of iOS, head to the Settings > General > Software Update. iOS 14.7.1 is the version you’ll need to install to make sure your smartphone is shielded against the zero-day flaw. iPad owners need to download iPadOS 14.7.1, while Mac owners need macOS Big Sur 11.5.1.

All three of these new software updates from Apple are available in the UK and worldwide now.



Leave a Reply

Your email address will not be published.